Diese Website ist optimiert für Firefox.   

Die Tippfarm

Excel: Nur bestimmte Elemente eines kopierten Bereichs einfügen (171)

Excel: Zwei Arbeitsblätter gleichzeitig anzeigen (144)

PowerPoint: Zehn Tipps für die bessere Präsentation (78)

Excel: SVERWEIS mit zwei Bedingungen (75)

Excel: Teile aus Zelltext auslesen (73)

Word: Einfache Anführungszeichen (72)

Excel: ZÄHLENWENN mit mehreren Bedingungen (42)

PowerPoint: Excel-Daten verknüpfen und aktualisieren (41)

PowerPoint: Bild erst bei Bedarf einblenden (39)

Excel: Die lästigen Seitenumbruchslinien loswerden (38)

Word: Seitenumbruch in Tabellen verhindern (36)

Outlook: Lästige Sicherheitsabfrage in Outlook abstellen (29)

PowerPoint: Datei einfügen und öffnen (29)

Excel: Excel-Tabelle auflösen/löschen (28)

PowerPoint: Referentenansicht für erweiterte Präsentationsmöglichkeiten (28)

PowerPoint: Text von Bild umfließen lassen (28)

Excel: Alle Excel-Tastenkombinationen (28)

PowerPoint: Folien-Seitenverhältnis festlegen (28)

PowerPoint: Aufzählungspunkte höher/tiefer stufen (28)

PowerPoint: Folienmaster bearbeiten (28)

PowerPoint: Aufzählungspunkte einzeln erscheinen lassen (27)

Excel: Summenprodukt mit Bedingung (27)

PowerPoint: Neue Folienübergänge (26)

Excel: Zeilen/Spalten gruppieren (26)

Word: Schnellbausteine weitergeben (26)

Excel: Zeilennummer eines bestimmten Inhalts finden (25)

Word: Datenquelle ändern (25)

Word: Bruchzahlen perfekt schreiben (25)

Excel: Mit Blitzvorschau zusammensetzen und gliedern (25)

Excel: Automatische Datentrennung (Blitzvorschau) (25)

Nr. 9: ZÄHLENWENN mit mehreren Bedingungen

Tippfarm auch auf:  XING und  Twitter 

Aus Rubrik: Excel - Formeln und Funktionen

Die Funktion ZÄHLENWENN kann nur eine einzige Bedingung verarbeiten. Wenn Sie mehrere Bedingungen verknüpfen wollen, geht das nur mit der Funktion SUMMENPRODUKT:

Geben Sie dazu die Funktion SUMMENPRODUKT mit den beiden Bedingungen als Argument ein.

Beispiel:
In einer längeren Liste (A1 bis B 50) steht in Spalte A die Branche (Großhandel), in Spalte B der Ort (Wien). Die Frage "Wie viele Großhändler habe ich in Wien? beantwortet die folgende Formel:

=SUMMENPRODUKT((A1:A50="Großhandel")*(B1:B50="Wien"))

Der Formel liegt die Tatsache zugrunde, dass Bedingungen mit dem Ergebnis 1 (für WAHR) bzw. 0 (für FALSCH) ausgewertet werden. Ist daher eine der Bedingungen nicht erfüllt, wird mit 0 multipliziert und das Ergebnis ist ebenfalls 0. Andernfalls: 1*1 = 1. Das funktioniert mit beliebig vielen Bedingungen, die Sie multiplizieren!

Ab Excel 2007 geht es noch einfacher mit der Funktion ZÄHLENWENNS. Die Funktion ist eine Abwandlung von ZÄHLENWENN mit dem Vorteil, mehrere Suchkrite-rien unterstützen zu können, was sie bei größeren Datenmengen wesentlich performanter macht.

Das obige Beispiel lösen Sie dann so:

ZÄHLENWENNS(Kriterienbereich1;Kriterien1;[Kriterienbereich2;Kriterium2]…)

daher:

=ZÄHLENWENNS(A1:A50;"Großhandel";B1:B50;"Wien")

Tipp getestet unter Excel 2007, 2010, 2013, 2016/19.

Eingestellt: 12.02.06 - Update: 27.01.2018 - Abrufe: 229.844