Diese Website ist optimiert für Firefox.   

Die Tippfarm

Excel: Nur bestimmte Elemente eines kopierten Bereichs einfügen (171)

Excel: Zwei Arbeitsblätter gleichzeitig anzeigen (144)

PowerPoint: Zehn Tipps für die bessere Präsentation (78)

Excel: SVERWEIS mit zwei Bedingungen (75)

Excel: Teile aus Zelltext auslesen (73)

Word: Einfache Anführungszeichen (72)

Excel: ZÄHLENWENN mit mehreren Bedingungen (42)

PowerPoint: Excel-Daten verknüpfen und aktualisieren (41)

PowerPoint: Bild erst bei Bedarf einblenden (39)

Excel: Die lästigen Seitenumbruchslinien loswerden (38)

Word: Seitenumbruch in Tabellen verhindern (36)

Outlook: Lästige Sicherheitsabfrage in Outlook abstellen (29)

PowerPoint: Datei einfügen und öffnen (29)

Excel: Excel-Tabelle auflösen/löschen (28)

PowerPoint: Referentenansicht für erweiterte Präsentationsmöglichkeiten (28)

PowerPoint: Text von Bild umfließen lassen (28)

Excel: Alle Excel-Tastenkombinationen (28)

PowerPoint: Folien-Seitenverhältnis festlegen (28)

PowerPoint: Aufzählungspunkte höher/tiefer stufen (28)

PowerPoint: Folienmaster bearbeiten (28)

PowerPoint: Aufzählungspunkte einzeln erscheinen lassen (27)

Excel: Summenprodukt mit Bedingung (27)

PowerPoint: Neue Folienübergänge (26)

Excel: Zeilen/Spalten gruppieren (26)

Word: Schnellbausteine weitergeben (26)

Excel: Zeilennummer eines bestimmten Inhalts finden (25)

Word: Datenquelle ändern (25)

Word: Bruchzahlen perfekt schreiben (25)

Excel: Mit Blitzvorschau zusammensetzen und gliedern (25)

Excel: Automatische Datentrennung (Blitzvorschau) (25)

Nr. 1316: Summenprodukt mit Bedingung

Tippfarm auch auf:  XING und  Twitter 

Aus Rubrik: Excel - Formeln und Funktionen

Mit der Funktion SUMMENPRODUKT können Sie die Produkte mehrerer Faktoren in einem Zug, ohne Verwendung einer zusätzlichen Spalte, addieren. Betrachten Sie in unserem Beispiel die Formel in der Zelle C13:

=SUMMENPRODUKT(B2:B11;C2:C11)

Die Funktion SUMMENPRODUKT multipliziert die entsprechenden Komponenten mehrerer Matrizen. Die Matrizen müssen natürlich gleich groß sein (B2:B11 und C2:C11).

Soweit, so gut! Aber was tun, wenn ich nur Komponenten multiplizieren will, die (eventuell in einer weiteren Matrix) eine Bedingung erfüllen müssen, um in die Berechnung einbezogen zu werden? Im Beispiel: Nur Umsätze eines bestimmten Verkäufers.

Die Bedingung steht in der Zelle B14. Berechnet sollen nur Werte werden, die im Bereich A2:A11 mit der Bedingung übereinstimmen:

  1. Die Bedingung formulieren:

    (A2:A11=B14)*1

    Das Ergebnis kann nur WAHR (=1) oder FALSCH (=0) sein.
    Die Multiplikation "*1" ist notwendig, damit das Ergebnis WAHR oder FALSCH auch in der Matrix korrekt als 0 bzw. 1 erkannt wird.
  2. Schreiben Sie die Funktion SUMMENPRODUKT, wobei das erste Argument die Matrix mit der Bedingungsprüfung und zwei weitere Argumente die Mengen- und Preismatrix darstellen:

    =SUMMENPRODUKT((A2:A11=B14)*1;B2:B11;C2:C11)

    In Zeile 2 des Beispiels ist die Bedingung nicht erfüllt, daher wird multipliziert: "0*1*4*3 = 0",
    Zeile 3 hingegen erfüllt die Bedingung, daher: "1*1*5*7,5 = 37,5".

Und schon haben Sie das Gesamtergebnis (=SUMMENPRODUKT) nur für die Zeilen, die die Bedingung erfüllen.

PS:
Walter Novotny weist darauf hin, dass die Formel auch mit mehreren Bedingungen funktioniert.
Es muss nur die Bedingung "(A2:A11=B14)*1", an die zusätzlichen Bedingungsspalten adaptiert, mehrfach eingesetzt werden.
Danke Walter!

Tipp getestet unter Excel 2007, 2010, 2013, 2016/19.

Eingestellt: 23.11.11 - Update: 13.02.2018 - Abrufe: 89.023