Diese Website ist optimiert für Firefox.   

Die Tippfarm

Excel: Nur bestimmte Elemente eines kopierten Bereichs einfügen (150)

Excel: Zwei Arbeitsblätter gleichzeitig anzeigen (127)

Excel: Teile aus Zelltext auslesen (74)

Excel: SVERWEIS mit zwei Bedingungen (74)

PowerPoint: Zehn Tipps für die bessere Präsentation (72)

Word: Einfache Anführungszeichen (67)

Excel: ZÄHLENWENN mit mehreren Bedingungen (49)

Excel: Die lästigen Seitenumbruchslinien loswerden (41)

PowerPoint: Excel-Daten verknüpfen und aktualisieren (40)

PowerPoint: Bild erst bei Bedarf einblenden (37)

Word: Seitenumbruch in Tabellen verhindern (36)

Excel: Excel-Tabelle auflösen/löschen (33)

PowerPoint: Aufzählungspunkte höher/tiefer stufen (30)

Excel: Zeilennummer eines bestimmten Inhalts finden (28)

PowerPoint: Datei einfügen und öffnen (28)

Outlook: Lästige Sicherheitsabfrage in Outlook abstellen (28)

Excel: Summenprodukt mit Bedingung (28)

Windows: Mausrad: Scrollrichtung umdrehen (28)

Excel: Zeilen/Spalten gruppieren (27)

Excel: Alle Excel-Tastenkombinationen (27)

Windows: Audio-CD (auch einzelne Titel) kopieren (27)

PowerPoint: Referentenansicht für erweiterte Präsentationsmöglichkeiten (27)

PowerPoint: Folienmaster bearbeiten (27)

PowerPoint: Folien-Seitenverhältnis festlegen (26)

PowerPoint: Text von Bild umfließen lassen (26)

Word: Bruchzahlen perfekt schreiben (26)

PowerPoint: Aufzählungspunkte einzeln erscheinen lassen (26)

Word: Schnellbausteine weitergeben (26)

Word: Datenquelle ändern (25)

Excel: Zählen mit mehreren Bedingungen (2) (25)

Nr. 1316: Summenprodukt mit Bedingung

Tippfarm auch auf:  XING und  Twitter 

Aus Rubrik: Excel - Formeln und Funktionen

Mit der Funktion SUMMENPRODUKT können Sie die Produkte mehrerer Faktoren in einem Zug, ohne Verwendung einer zusätzlichen Spalte, addieren. Betrachten Sie in unserem Beispiel die Formel in der Zelle C13:

=SUMMENPRODUKT(B2:B11;C2:C11)

Die Funktion SUMMENPRODUKT multipliziert die entsprechenden Komponenten mehrerer Matrizen. Die Matrizen müssen natürlich gleich groß sein (B2:B11 und C2:C11).

Soweit, so gut! Aber was tun, wenn ich nur Komponenten multiplizieren will, die (eventuell in einer weiteren Matrix) eine Bedingung erfüllen müssen, um in die Berechnung einbezogen zu werden? Im Beispiel: Nur Umsätze eines bestimmten Verkäufers.

Die Bedingung steht in der Zelle B14. Berechnet sollen nur Werte werden, die im Bereich A2:A11 mit der Bedingung übereinstimmen:

  1. Die Bedingung formulieren:

    (A2:A11=B14)*1

    Das Ergebnis kann nur WAHR (=1) oder FALSCH (=0) sein.
    Die Multiplikation "*1" ist notwendig, damit das Ergebnis WAHR oder FALSCH auch in der Matrix korrekt als 0 bzw. 1 erkannt wird.
  2. Schreiben Sie die Funktion SUMMENPRODUKT, wobei das erste Argument die Matrix mit der Bedingungsprüfung und zwei weitere Argumente die Mengen- und Preismatrix darstellen:

    =SUMMENPRODUKT((A2:A11=B14)*1;B2:B11;C2:C11)

    In Zeile 2 des Beispiels ist die Bedingung nicht erfüllt, daher wird multipliziert: "0*1*4*3 = 0",
    Zeile 3 hingegen erfüllt die Bedingung, daher: "1*1*5*7,5 = 37,5".

Und schon haben Sie das Gesamtergebnis (=SUMMENPRODUKT) nur für die Zeilen, die die Bedingung erfüllen.

PS:
Walter Novotny weist darauf hin, dass die Formel auch mit mehreren Bedingungen funktioniert.
Es muss nur die Bedingung "(A2:A11=B14)*1", an die zusätzlichen Bedingungsspalten adaptiert, mehrfach eingesetzt werden.
Danke Walter!

Tipp getestet unter Excel 2007, 2010, 2013, 2016/19.

Eingestellt: 23.11.11 - Update: 13.02.2018 - Abrufe: 100.224