Diese Website ist optimiert für Firefox.   

Die Tippfarm

Excel: Nur bestimmte Elemente eines kopierten Bereichs einfügen (148)

Excel: Zwei Arbeitsblätter gleichzeitig anzeigen (126)

Excel: Teile aus Zelltext auslesen (74)

Excel: SVERWEIS mit zwei Bedingungen (73)

PowerPoint: Zehn Tipps für die bessere Präsentation (72)

Word: Einfache Anführungszeichen (67)

Excel: ZÄHLENWENN mit mehreren Bedingungen (50)

Excel: Die lästigen Seitenumbruchslinien loswerden (41)

PowerPoint: Excel-Daten verknüpfen und aktualisieren (40)

PowerPoint: Bild erst bei Bedarf einblenden (37)

Word: Seitenumbruch in Tabellen verhindern (36)

Excel: Excel-Tabelle auflösen/löschen (33)

PowerPoint: Aufzählungspunkte höher/tiefer stufen (30)

Excel: Zeilennummer eines bestimmten Inhalts finden (29)

Windows: Mausrad: Scrollrichtung umdrehen (28)

PowerPoint: Datei einfügen und öffnen (28)

Excel: Summenprodukt mit Bedingung (28)

Outlook: Lästige Sicherheitsabfrage in Outlook abstellen (28)

Excel: Zeilen/Spalten gruppieren (27)

Excel: Alle Excel-Tastenkombinationen (27)

Windows: Audio-CD (auch einzelne Titel) kopieren (27)

PowerPoint: Referentenansicht für erweiterte Präsentationsmöglichkeiten (27)

PowerPoint: Folienmaster bearbeiten (27)

PowerPoint: Folien-Seitenverhältnis festlegen (26)

Word: Bruchzahlen perfekt schreiben (26)

PowerPoint: Text von Bild umfließen lassen (26)

PowerPoint: Aufzählungspunkte einzeln erscheinen lassen (26)

Word: Schnellbausteine weitergeben (26)

Word: Datenquelle ändern (25)

Excel: Zählen mit mehreren Bedingungen (2) (25)

Nr. 9: ZÄHLENWENN mit mehreren Bedingungen

Tippfarm auch auf:  XING und  Twitter 

Aus Rubrik: Excel - Formeln und Funktionen

Die Funktion ZÄHLENWENN kann nur eine einzige Bedingung verarbeiten. Wenn Sie mehrere Bedingungen verknüpfen wollen, geht das nur mit der Funktion SUMMENPRODUKT:

Geben Sie dazu die Funktion SUMMENPRODUKT mit den beiden Bedingungen als Argument ein.

Beispiel:
In einer längeren Liste (A1 bis B 50) steht in Spalte A die Branche (Großhandel), in Spalte B der Ort (Wien). Die Frage "Wie viele Großhändler habe ich in Wien? beantwortet die folgende Formel:

=SUMMENPRODUKT((A1:A50="Großhandel")*(B1:B50="Wien"))

Der Formel liegt die Tatsache zugrunde, dass Bedingungen mit dem Ergebnis 1 (für WAHR) bzw. 0 (für FALSCH) ausgewertet werden. Ist daher eine der Bedingungen nicht erfüllt, wird mit 0 multipliziert und das Ergebnis ist ebenfalls 0. Andernfalls: 1*1 = 1. Das funktioniert mit beliebig vielen Bedingungen, die Sie multiplizieren!

Ab Excel 2007 geht es noch einfacher mit der Funktion ZÄHLENWENNS. Die Funktion ist eine Abwandlung von ZÄHLENWENN mit dem Vorteil, mehrere Suchkrite-rien unterstützen zu können, was sie bei größeren Datenmengen wesentlich performanter macht.

Das obige Beispiel lösen Sie dann so:

ZÄHLENWENNS(Kriterienbereich1;Kriterien1;[Kriterienbereich2;Kriterium2]…)

daher:

=ZÄHLENWENNS(A1:A50;"Großhandel";B1:B50;"Wien")

Tipp getestet unter Excel 2007, 2010, 2013, 2016/19.

Eingestellt: 12.02.06 - Update: 27.01.2018 - Abrufe: 284.424 
Danke für Ihre Bewertung 2="Hilfreich"