Diese Website ist optimiert für Firefox.   

Die Tippfarm

Excel: Rang innerhalb einer Zahlenliste (1.57)

Excel: PowerPivot installieren (1.62)

Outlook: Tolle Anti-Spam-Liste: SpamPal (1.64)

Excel: Postleitzahlentabelle Österreich (1.72)

PowerPoint: PowerPoint to Flash Converter - iSpring Free (1.86)

Internet: Topleveldomains einschränken (1.87)

Word: Dokumentvorlagen auf mehrere Register aufteilen (1.88)

Windows: Dateien ins Zip-Archiv ziehen (1.92)

Internet: Suche nach exakter Schreibweise erzwingen (1.92)

PowerPoint: Text von Bild umfließen lassen (1.95)

Internet: In Webadresse (URL) suchen (1.98)

Excel: Registerkarte Entwicklertools anzeigen (1.98)

Excel: Alphanumerische Zahlensortierung (2.01)

Word: Anführungszeichen korrekt setzen (2.02)

Outlook: Archivierte Daten ansehen (2.02)

Excel: Zelladressen und Zellbezugsarten (2.04)

Hard-, Software, IT-Security: PDF-Formulare erstellen (2.04)

PowerPoint: Mit dem PowerPoint-Lineal arbeiten (2.04)

PowerPoint: Interaktive Schaltflächen selbst anfertigen (2.05)

Internet: Kostenlose Dateikonvertierung (2.05)

Internet: Favoriten alphabetisch sortieren (2.05)

Excel: ZÄHLENWENN mit mehreren Bedingungen (2.06)

Excel: Verknüpfung mit Doppelklick anwählen (2.06)

Excel: Mittelwert von Wahrheitswerten berechnen (2.07)

PowerPoint: Transparente Schrift (2.07)

PowerPoint: Ein gewelltes Band erstellen (2.07)

PowerPoint: Zahlen in Tabellen vertikal besser ausrichten (2.07)

Word: Tools zum einfachen Bearbeiten von Tabellen (2.07)

PowerPoint: Neue grafische Formen entwickeln (2.07)

Hard-, Software, IT-Security: Mit einer Maus/Tastatur mehrere PCs steuern (2.07)

Nr. 9: ZÄHLENWENN mit mehreren Bedingungen

Tippfarm auch auf:  XING und  Twitter 

Aus Rubrik: Excel - Formeln und Funktionen

Die Funktion ZÄHLENWENN kann nur eine einzige Bedingung verarbeiten. Wenn Sie mehrere Bedingungen verknüpfen wollen, geht das nur mit der Funktion SUMMENPRODUKT:

Geben Sie dazu die Funktion SUMMENPRODUKT mit den beiden Bedingungen als Argument ein.

Beispiel:
In einer längeren Liste (A1 bis B 50) steht in Spalte A die Branche (Großhandel), in Spalte B der Ort (Wien). Die Frage "Wie viele Großhändler habe ich in Wien? beantwortet die folgende Formel:

=SUMMENPRODUKT((A1:A50="Großhandel")*(B1:B50="Wien"))

Der Formel liegt die Tatsache zugrunde, dass Bedingungen mit dem Ergebnis 1 (für WAHR) bzw. 0 (für FALSCH) ausgewertet werden. Ist daher eine der Bedingungen nicht erfüllt, wird mit 0 multipliziert und das Ergebnis ist ebenfalls 0. Andernfalls: 1*1 = 1. Das funktioniert mit beliebig vielen Bedingungen, die Sie multiplizieren!

Ab Excel 2007 geht es noch einfacher mit der Funktion ZÄHLENWENNS. Die Funktion ist eine Abwandlung von ZÄHLENWENN mit dem Vorteil, mehrere Suchkrite-rien unterstützen zu können, was sie bei größeren Datenmengen wesentlich performanter macht.

Das obige Beispiel lösen Sie dann so:

ZÄHLENWENNS(Kriterienbereich1;Kriterien1;[Kriterienbereich2;Kriterium2]…)

daher:

=ZÄHLENWENNS(A1:A50;"Großhandel";B1:B50;"Wien")

Tipp getestet unter Excel 2007, 2010, 2013, 2016/19.

Eingestellt: 12.02.06 - Update: 27.01.2018 - Abrufe: 331.896